Actualización a Ubuntu 10.04 Lucid Lynx

Hace dos días, 29 de abril, salió Ubuntu 10.04 Lucid Lynx.

Es una nueva versión de una de las distribuciones más usadas en todo el mundo que en este caso es Long Term Support, es decir, que la empresa Canonical da soporte con esta versión por un largo periodo de tiempo (hasta abril de 2013).

Muchos usuarios ya han actualizado y  han podido ver su nueva renovada interfaz con la que Canonical pretende orientar su Sistema Operativo hacia las redes sociales (Twitter, Facebook, Flickr..) con su nuevo programa integrado Gwibber.
Aunque lo que sin lugar a dudas sorprenderá más a los usuarios que utilicen este “Lince lúcido” será la actualización de Gnome en la que se cambia de lugar los botones de Cerrar, Maximizar y Minimizar de la derecha a la izquierda. También podemos comprobar que ahora tenemos hasta 4 escritorios.En mi caso actualicé desde Ubuntu 9.10 Karmic Koala a través del Gestor de Actualizaciones. Tuve algunos problemas en la parte de descargas de paquetes nuevos, me dio fallos de conexión a Internet y tuve que reiniciar varias veces la actualización con la suerte de que los paquetes ya descargados se conservan.Una vez descargados cuando procedía a actualizar me dio un fallo con la nueva versión de Wine 1.2 que fue omitida durante este proceso. Luego más tarde, cuando todo terminó, solucioné este problema reinstalando Wine desde el Gestor de paquetes Synaptic.

Otra sorpresa fue ver que no podía ver vídeos en Internet ya que se había desinstalado o no era compatible con la nueva versión adaptada de Firefox, Adobe Flash Player. Mi problema mayor fue que al ser mi ordenador de arquitectura x64 no podía instalarlo a través de la web de Adobe así que gracias al blog nixCraft vi la forma de solucionarlo con este simple script que escribiremos en nuevo archivo con la extensión .sh y que ejecutaremos desde la terminal (Aplicaciones->Accesorios->Terminal) con el comando:
sh firefoxflash.sh

#!/bin/bash
# Script created by
# Romeo-Adrian Cioaba romeo.cioaba@spotonearth.com
# Super minor updates by jason.melton[at]gmail[dot]com
# Updates by Alejandro Cuervo 3[at]cuervo[dot]net
# Released under GPL
echo "Cerrando Firefox"
sudo killall -9 firefox
echo "Descargando e instalando las librerías requeridas Getlibs."
wget http://frozenfox.freehostia.com/cappy/getlibs-all.deb
sudo dpkg -i getlibs-all.deb
echo "Desinstalando versiones previas de flash:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper
echo "Instalando ia32-libs y nspluginwrapper"
sudo apt-get install ia32-libs nspluginwrapper
echo "Obteniendo librerías"
sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d
echo "Instalando Flash Player 10"
cd ~
wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
tar zxvf install_flash_player_10_linux.tar.gz
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
rm -rf install_flash_player_10_linux.tar.gz libflashplayer.so
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
echo "Vinculando las librerías para que firefox las pueda ver."
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so/usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/npwrapper.libflashplayer.so /usr/lib/firefox-addons/plugins/
echo "Terminado"
echo "Ya puedes iniciar Firefox"

Una vez finalizado el proceso ya pude disfrutar de flash en mi nuevo Ubuntu 10.04 LTS 🙂

Anuncios

11 pensamientos en “Actualización a Ubuntu 10.04 Lucid Lynx

  1. Una preguntilla. Tengo dos usuarios en mi ubuntu. El script lo he ejecutado en el principal, y funciona perfectamente. El problema está en el otro usuario, en el que sigue sin funcionar.
    (Si ésto ya es abusar, elimíname el comentario)

    Gracias y un saludo.

  2. Primero muchas gracias por tus comentarios. Son estos los que nos hacen continuar escribiendo. Nunca eliminaremos uno a no ser que incumpla alguna normativa, por ser ofensivo por ejemplo, así que no te cortes que puede que tu problema que le suceda a otra persona y le podamos ayudar a ella también.

    He estado revisando el script y me he fijado que la dirección de descarga de las librerías GetLibs que se necesitan de requisito estaba mal, ya la he corregido así que te sugiero que lo cambies y vuelvas a intentarlo.
    Puede que el problema se deba a una falta de permisos así que te sugiero que en la terminal primero hagas “su” y entres como superusuario, después ejecuta el script y comprueba que tras cada paso no te reporte ningún error. Si en caso de haber revisado todos los mensajes que devuelve no haya ningún, prueba a escribir cada comando o línea en la consola directamente, sin utilizar un script (las líneas precedidas por “#” o “echo” no hace falta que las escribas)

    En cualquier caso dinos como te ha ido, un saludo
    pleoNeX

  3. Aún se resiste.
    Primero, gracias por contestar. No he respondido antes porque estos días he estado liado.
    Usando SU el script se ejecuta sin errores, pero no funciona.
    Al ejecutarlo línea a línea veo dos errores:

    sudo apt-get install ia32-libs nspluginwrapper
    No se puede encontrar el paquete ia32-libs

    root@juanjo-desktop:~# sudo nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
    sudo: nspluginwrapper: command not found

    No sé si puede ayudar

  4. Genial, muchas gracias, me ha servido lo del flash tambien para el 32 bits, que funcionaba el sonido solo una vez despues de reinstalar el plugin, luego ya, sin sonido, problema solucionado

  5. Vuelvo a la carga. 🙂
    He descubierto lo siguiente:
    si en el usuario que no funciona en el firefox escribo about:plugins me aparecen DOS plugin de flash: Shockwave Flash 10.0 r42 y el 10.0 r45. En Firefox>Herramientas>Plugins me aparece sólo el r42. Si lo desactivo no se me ven los vídeos en flash (por plugin inactivo) pero la web checkplugin me dice que está actualizado. Si lo activo los vídeos en flash hacen crash y en la web checkplugin me dicen que he de actualizar.
    ¿Cómo se podría “decirle” al firefox que se quede con el plugin r45 y deseche el r42?
    Gracias por adelantado.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s